ROS软路由设置单线复用iTV+上网

作者 : 七界传说 发布时间: 2020-11-28 文章热度:737 共1138个字,阅读需3分钟。 本文内容有更新

目 录

理想状态应该是这样的:

  1. 光纤入户,光猫直接安装在家里的弱电箱里。
  2. 光猫连接两条网线,一条负责ITV传输,一条负责网络传输
  3. 两条网线分别连接路由器和机顶盒,各司其职,互不干扰

实际情况是这样的:

目前大部分精装商品房从弱电箱到客厅电视这里只放了一条网线。要么选择没网看电视。要么选择没电视上网

单线复用就是一个应对上面情况进行多组数据使用一条网线的功能

今天就来教大家一种单线双用的方法,首先我们需要准备如下

硬件:

1.光纤猫,这个安装宽带网络都会赠送

2.一个可以支持划分VLAN(虚拟专用网络)的路由器

节省一台vlan交换机

网络拓扑图

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

光猫设置vlan绑定

  1. 要有超级密码
  2. vlan填你自己地区

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

ROS路由设置

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建vlan,ether1是拨号口

/interface vlan
add name=vlan1111 vlan-id=1111 interface=ether1
add name=vlan1112 vlan-id=1112 interface=ether1
add name=vlan3990 vlan-id=3990 interface=ether1

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建bridge

/interface bridge
add name=vWAN1 vlan-filtering=yes pvid=1111 admin-mac=A2:45:FE:54:2C:3C
add name=vWAN2 vlan-filtering=yes pvid=1112 admin-mac=A2:45:FE:54:2C:4D
add name=iTV-LAN vlan-filtering=no admin-mac=A2:45:FE:54:2C:5B igmp-snooping=yes

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

绑定桥接网口,ether2内网口

/interface bridge port
add bridge=vWAN1 interface=vlan1111 pvid=1111
add bridge=vWAN2 interface=vlan1112 pvid=1112
add bridge=iTV-LAN interface=vlan3990 pvid=3990
add bridge=iTV-LAN interface=ether2 pvid=1

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

设置接口IP

/ip address
add address=192.168.2.111 interface=vWAN1
add address=192.168.3.111 interface=vWAN2
add address=1.1.1.1 interface=vlan399

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建IGMP Proxy

/routing igmp-proxy interface
add interface=vlan3990 upstream=yes 
add interface=iTV-LAN

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

命令输入完检查是否有错

接上机顶盒在内网里也可以观看

ROS软路由设置单线复用iTV+上网-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

2 评论

  1. 这个会影响上网的带宽吗?另外,如果是ROS+OpenWrt的主路由+旁路由的配置,如何实现组播转串流?谢谢。

发表评论

7
+706天安全运行
主题分享
1
+1篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

站点地图