ROS脚本大全(通用)

作者 : 七界传说 发布时间: 2020-04-19 文章热度:781 共5153个字,阅读需13分钟。

目 录

ROS脚本大全(通用)-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

前言:

如果你刚接触RouterOS系统的路由器,这里有ROS脚本生成器软件管理工具和教程,希望它能给中国广大的ROS爱好者和用户带来便利!

一、限速脚本

1
:for wbsz from 1 to 254 do={/queue simple add name=(wbsz . $wbsz) dst-address=(192.168.0. . $wbsz) limit-at=1024K/1024K max-limit=1024K/1024K}

二、限制每台机最大线程数

1
:for wbsz from 1 to 254 do={/ip firewall filter add chain=forward src-address=(192.168.0. . $wbsz) protocol=tcp connection-limit=50,32 action=drop}

三、端口映射

1
ip firewall nat add chain=dstnat dst-address=(202.96.134.134) protocol=tcp dst-port=80 to-addresses=(192.168.0.1) to-ports=80 action=dst-nat

四、封端口号

1
2
/ ip firewall filter
ad ch forward pr tcp dst-po 8000 act drop comment="Blockade QQ"

五、更变telnet服务端口

1
/ip service set telnet port=23

六、更变SSH管理服务端口

1
/ip service set ssh port=22

七、更变www服务端口号

1
/ip service set www port=80

八、更变FTP服务端口号

1
/ip service set ftp port=21

九、增加本ROS管理用户

1
/user add name=wbsz password=admin group=full

十、删除限速脚本

1
:for wbsz from 1 to 254 do={/queue simple remove (wbsz . $wbsz) }

十一、封IP脚步本

1
2
/ ip firewall filter
add chain=forward dst-address=58.60.13.38/32 action=drop comment="Blockade QQ"

十二、禁P2P脚本

1
2
/ ip firewall filter
add chain=forward src-address=192.168.0.0/24 p2p=all-p2p action=drop comment="No P2P"

十三、限制每台机最大的TCP线程数(线程数=60)

1
2
3
/ ip firewall filter
add chain=forward protocol=tcp connection-limit=60,32 action=drop \
disabled=no

十四、一次性绑定所有在线机器MAC

1
:foreach wbsz in=[/ip arp find dynamic=yes ] do=[/ip arp add copy-from=$wbsz]

十五、解除所以绑定的MAC

1
:foreach wbsz in [/ip arp find] do={/ip arp remove $wbsz}

十六、禁Ping

1
2
/ ip firewall filter
add chain=output protocol=icmp action=drop comment="No Ping"

十七、禁电驴

1
2
3
4
/ ip firewall filter
add chain=forward protocol=tcp dst-port=4661-4662 action=drop comment="No Emule"
add chain=forward protocol=tcp dst-port=4242 action=drop
add chain=forward dst-address=62.241.53.15 action=drop

十八、禁PPLIVE

1
2
3
4
/ ip firewall filter
add chain=forward protocol=tcp dst-port=8008 action=drop comment="No PPlive TV"
add chain=forward protocol=udp dst-port=4004 action=drop
add chain=forward dst-address=218.108.237.11 action=drop

十九、禁QQ直播

1
2
/ ip firewall filter
add chain=forward protocol=udp dst-port=13000-14000 action=drop comment="No QQLive"

二十、禁比特精灵

1
2
/ ip firewall filter
add chain=forward protocol=tcp dst-port=16881 action=drop comment="No BitSpirit"

二十一、禁QQ聊天(一般公司才需要)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
/ ip firewall filter
add chain=forward src-address=10.5.6.7/32 action=accept comment="No Tencent QQ"
ad ch forward pr tcp dst-po 8000 act drop
ad ch forward pr udp dst-po 8000 act drop
ad ch forward pr udp dst-po 8000 act drop
add chain=forward dst-address=61.144.238.0/24 action=drop
add chain=forward dst-address=61.152.100.0/24 action=drop
add chain=forward dst-address=61.141.194.0/24 action=drop
add chain=forward dst-address=202.96.170.163/32 action=drop
add chain=forward dst-address=202.104.129.0/24 action=drop
add chain=forward dst-address=202.104.193.20/32 action=drop
add chain=forward dst-address=202.104.193.11/32 action=drop
add chain=forward dst-address=202.104.193.12/32 action=drop
add chain=forward dst-address=218.17.209.23/32 action=drop
add chain=forward dst-address=218.18.95.153/32 action=drop
add chain=forward dst-address=218.18.95.165/32 action=drop
add chain=forward dst-address=218.18.95.220/32 action=drop
add chain=forward dst-address=218.85.138.70/32 action=drop
add chain=forward dst-address=219.133.38.0/24 action=drop
add chain=forward dst-address=219.133.49.0/24 action=drop
add chain=forward dst-address=220.133.40.0/24 action=drop
add chain=forward content=sz.tencent action=reject
add chain=forward content=sz2.tencent action=reject
add chain=forward content=sz3.tencent action=reject
add chain=forward content=sz4.tencent action=reject
add chain=forward content=sz5.tencent action=reject
add chain=forward content=sz6.tencent action=reject
add chain=forward content=sz7.tencent action=reject
add chain=forward content=sz8.tencent action=rejec
add chain=forward content=sz9.tencent action=rejec
add chain=forward content=tcpconn.tencent action=reject
add chain=forward content=tcpconn2.tencent action=reject
add chain=forward content=tcpconn3.tencent action=reject
add chain=forward content=tcpconn4.tencent action=reject
add chain=forward content=tcpconn5.tencent action=reject
add chain=forward content=tcpconn6.tencent action=reject
add chain=forward content=tcpconn7.tencent action=reject
add chain=forward content=tcpconn8.tencent action=reject
add chain=forward content=qq action=reject
add chain=forward content=www.qq action=reject

二十二、防止灰鸽子入浸

1
2
3
4
5
6
7
8
9
10
11
12
/ ip firewall filter
add chain=forward protocol=tcp dst-port=1999 action=drop comment="Backdoor.GrayBird.ad"
add chain=forward dst-address=80.190.240.125 action=drop
add chain=forward dst-address=203.209.245.168 action=drop
add chain=forward dst-address=210.192.122.106 action=drop
add chain=forward dst-address=218.30.88.43 action=drop
add chain=forward dst-address=219.238.233.110 action=drop
add chain=forward dst-address=222.186.8.88 action=drop
add chain=forward dst-address=124.42.125.37 action=drop
add chain=forward dst-address=210.192.122.107 action=drop
add chain=forward dst-address=61.147.118.198 action=drop
add chain=forward dst-address=219.238.233.11 action=drop

二十三、防三波

1
2
/ ip firewall filter
add chain=forward protocol=tcp dst-port=135-139 action=drop comment="No 3B"

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

4 评论

  1. 好多年以前玩过ros,脚本功能强大,就是使用起来不够人性化。

  2. 现在在用,功能很强大。

  3. noip的脚本怎么没看见?

发表评论

6
+610天安全运行
主题分享
5
+5篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

站点地图