Ros设置Vlan交换机以支持多线adsl

作者 : 七界传说 发布时间: 2020-04-18 文章热度:363 共1282个字,阅读需4分钟。

Ros设置Vlan交换机以支持多线adsl-七界传说 | 关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

 

1、你可能没有四张网卡,需要用到Vlan交换机;
这个需要你的交换机支持802.1Q,所需要拨号的四个交换机端口(也就是连着四个ADSL猫的端口)都设置成access模式,vlanID分别是10、20、30、40(当然,其他的数字也可以)。连接RouterOS外线网卡的端口设置成trunk模式,并且允许以上vlan通过,在routeros的wan口建立4个vlan,vlanID分别为10、20、30、40(需要与交换机上的对应),这样就保证的了多个猫之间不会互相干扰,但是都可以和routeros上的虚拟vlan接口通讯

代码如下:

1
2
3
4
5
/interface vlan
add arp=enabled disabled=no interface=wan mtu=1500 name=vlan10 vlan-id=10
add arp=enabled disabled=no interface=wan mtu=1500 name=vlan20 vlan-id=20
add arp=enabled disabled=no interface=wan mtu=1500 name=vlan30 vlan-id=30
add arp=enabled disabled=no interface=wan mtu=1500 name=vlan40 vlan-id=40

2、ADSL无法拨上号,因为用来拨号的mac都一样;
如果你的vlan都是附着在wan口上面的,因此所有vlan虚拟接口的MAC地址都是同一个,因此电信局端检测到两个相同的mac在尝试用两个不同的账号同时拨号的时候就会断掉其中一个,这也是为什么有的无法同时拨号的原因。
解决办法就是通过添加桥即bridge,我感觉添加图片太麻烦,给出个脚本吧:

代码如下:

1
2
3
4
5
6
7
8
9
10
/interface bridge
add name=bridge10 admin-mac=11:11:11:11:11:11 disabled=no
add name=bridge20 admin-mac=22:22:22:22:22:22 disabled=no
add name=bridge30 admin-mac=33:33:33:33:33:33 disabled=no
add name=bridge40 admin-mac=44:44:44:44:44:44 disabled=no
/interface bridge port
add bridge=bridge10 interface=vlan10 disabled=no
add bridge=bridge20 interface=vlan20 disabled=no
add bridge=bridge30 interface=vlan30 disabled=no
add bridge=bridge40 interface=vlan40 disabled=no

这样,设置拨号的时候,选择interface为bridge10- bridge40,而不是vlan10-vlan40,这样子的话,拨号就不会存在mac地址冲突而无法拨号的情况了

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

发表评论

5
+542天安全运行
主题分享
2
+2篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

站点地图