ROS动态公网自动解析阿里云DDNS

作者 : 七界传说 发布时间: 2020-08-13 文章热度:1.6K 共851个字,阅读需3分钟。 本文内容有更新

目 录

ROS动态公网自动解析阿里云DDNS-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

一、创建访问控制RAM的AccessKey

1.打开阿里云网站 –> 控制台 –> 用户 –>AccessKey

ROS动态公网自动解析阿里云DDNS-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

2.创建使用子用户AccessKey

ROS动态公网自动解析阿里云DDNS-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

二、ROS上创建定时运行脚本

1.打开System–>Scheduler

ROS动态公网自动解析阿里云DDNS-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!2.创建运行脚本

ROS动态公网自动解析阿里云DDNS-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

(我这里有就不添加)

三、ROS脚本

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#aliyun Access Key
:local id "你的AccessKey ID"
:local secret "你的AccessKey ID"
#domain
:local domain "你的域名"
:local record "你的二级域名"
#PPPoE-out
:local pppoe "你的拨号接口名称"

:local ipaddr [/ip address get [/ip address find interface=$pppoe] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
:global aliip
:if ($ipaddr != $aliip) do={
:local result [/tool fetch url="http://u.myxzy.com/alidns/\?id=$id&secret=$secret&domain=$domain&record=$record&ip=$ipaddr" as-value output=user];
:if ($result->"status" = "finished") do={
:if ($result->"data" = "0") do={
:set aliip $ipaddr
:log info "alidns update ok";
} else={
:log info "alidns update error";
}
}
}

1、只支持A记录,TTL为600(10分钟),线路是默认线路

2、ip填入不带,默认是来源的IPv4地址

3、不支持IPv6

4、解析记录不存在会自动新建解析记录,存在则修改解析

5、多线路相同主机名记录只能识别列表第一条主机名解析记录

6、暂不提供源码

感谢博主:星知苑

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

5 评论

  1. 设置都没错,解析失败怎么处理?

  2. 您好博主,请问下严格按教程执行。id和secret都换了3次了,就是一直没效果。确认设置没错代码也没输错。
    手动解析宽带IP以后可以连接,但是重启以后解析就会失效。不过这种情况下连接wifi解析就可以用,实在不知道怎么解决了。
    可以解答一下吗?作者的API接口返回值一直是1,但是确认设置没错,希望博主帮忙解答一下不胜感激

  3. ros /system script environmment下面空的,f3322的配置也没有。我设置了2个ddns一个f3322的成功使用,阿里云的就不行。
    设置步骤:阿里子用户,创建新用户,新策略,输入代码,再进行授权。然后将ROS的代码拷进去,该改的都改了。f3322的解析会在ros log里面显示,但是阿里的没反应,显示代码和自动执行任务执行了一千多次都不成功。手动解析以后不连接wifi可以使用,但是重启或更换IP后就失效,并且当阿里的解析和宽带IP对应不上的时候,连接wifi使用域名竟然也出奇的可以使用。 实在是懵了!!
    我用爱快、高格等固件阿里云的解析就可以使用,同样是accesskey ID和SECRET,希望博主帮忙解答一下,不胜感激

发表评论

6
+702天安全运行
主题分享
1
+1篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

站点地图