MikroTik 异地组网+ospf

作者 : 七界传说 发布时间: 2021-12-23 文章热度:3.85K 共1412个字,阅读需4分钟。

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯彻(Dijkstra)算法被用来计算最短路径树。OSPF支持负载均衡和基于服务类型的选路,也支持多种路由形式,如特定主机路由和子网路由等

MikroTik1:177.15.2.2/24  MikroTik2:177.157.6.6/24

先创建MikroTik1环回接口

/interface bridge add name=Loopback0

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

设置环回接口IP

/ip address add address=3.3.3.5/32 interface=Loopback0

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建GRE Tunne

/interface gre add name=To_Home remote-address=公网IP地址      (注:这里改成自己的公网IP)

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

设置GRE IP地址

/ip address add address=10.10.0.2/30 interface=To_Home

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建ospf

/routing ospf instance add name=ospf1 router-id=3.3.3.5

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建Area ID

/routing ospf area add name=area1 instance=ospf1 area-id=1.1.1.1

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建宣告网段

/routing ospf network
add network=3.3.3.5/32 area=area1
add network=10.10.0.0/30 area=area1
add network=177.15.2.0/24 area=area1

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

配置好MikroTik1,接下来配置MikroTik2

创建MikroTik2环回接口

/interface bridge add name=Loopback0

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

设置环回接口IP

/ip address add address=3.3.3.3/32 interface=Loopback0

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建GRE Tunne

/interface gre add name=To_Gs remote-address=公网IP地址      (注:这里改成自己的公网IP)

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

设置GRE IP地址

/ip address add address=10.10.0.1/30 interface=To_Gs

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建ospf

/routing ospf instance add name=ospf1 router-id=3.3.3.3

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建Area ID

/routing ospf area add name=area1 instance=ospf1 area-id=1.1.1.1

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建宣告网段

/routing ospf network
add network=3.3.3.3/32 area=area1
add network=10.10.0.0/30 area=area1
add network=177.157.6.0/24 area=area1

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

至此两边MikroTik已配置完成,接下来我们看看两边路由表

查看MikroTik1上路由表

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

ping MikroTik2下监控这个IP地址:177.157.6.100

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

查看MikroTik2上路由表

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

ping MikroTik1下NAS这个IP地址:177.15.2.12

MikroTik 异地组网+ospf-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
已经能互访,用公网最稳定

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

发表评论

19
+1975天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图