MikroTik搭建动态公网域名解析

作者 : 七界传说 发布时间: 2023-06-26 文章热度:1.9K 共702个字,阅读需2分钟。 本文内容有更新

今天推荐的这个Docker容器DDNS-GO”,顾名思义,就是用来做DDNS的,支持国内的阿里云、腾讯云、华为云这三大域名商,以及支持国外大名鼎鼎的Cloudflare,同时支持IPv4和IPv6解析。如果使用的是上述域名,并且需要在 MikroTik设置DDNS解析的,可以使用这个Docker容器。

容器:ddns-go

打包好x86平台:下载  密码:bgu5

快速通道:点击

MikroTik搭建动态公网域名解析-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

命令行:

容器接口

/interface veth add name=DDNS_Eth address=192.168.8.3/24 gateway=192.168.8.8

绑定接口

/interface bridge port add interface=DDNS_Eth bridge=Bridge

创建映射文件

/container/mounts/add name=ddns_dir src=/docker/ddns-go dst=/root

映射端口

/container/envs/add name=ddns_ev key=PORT value=9876

MikroTik搭建动态公网域名解析-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
创建容器

/container/add file=amd_x86_64/ddns-go_x86_64.tar interface=DDNS_Eth envlist=ddns_ev root-dir=docker/images/ddns-go mounts=ddns_dir dns=192.168.8.6 start-on-boot=yes logging=no

MikroTik搭建动态公网域名解析-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

 创建好启动容器 web输入http://192.168.8.3:9876

MikroTik搭建动态公网域名解析-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

演示用阿里云domains:域名 AccessKey ID与AccessKey Secret对应填写

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

3 评论

  1. 按照你的方法,欢乐最新ddns-go版本,最后显示网络不可达,不能获取ipv6

  2. 我修改了address为自己的10.10.10.2/24,网关10.10.10.253,dns修改成自己的10.10.10.253,还修改了/interface bridge port add interface=DDNS_Eth bridge=Bridge为/interface bridge port add interface=DDNS_Eth bridge=bridge1,哪里错了吗

  3. 获取到的ipv6地址是docker 容器的地址。不是ros的地址,有什么办法解决吗

发表评论

19
+1923天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图