MikroTik搭建IPTV组播转单播

作者 : 七界传说 发布时间: 2023-06-26 文章热度:4.53K 共2617个字,阅读需7分钟。

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

IPTV中继服务,将IGMP转换为HTTP流

容器:udpxy

打包好x86平台:下载  密码:bgu5

快速通道:点击

1.交换机配置镜像功能

8口接光猫IPTV进线
7口接机顶盒镜像口
6口连接电脑观察口
10口连接软路由wan拨号

<huawei>sys
[huawei]observe-port interface GigabitEthernet 0/0/6
[huawei]interface GigabitEthernet0/0/7
[huawei-GigabitEthernet0/0/7]description jxk_jdh
[huawei-GigabitEthernet0/0/7]port link-type access
[huawei-GigabitEthernet0/0/7]port default vlan 43
[huawei-GigabitEthernet0/0/7]mirror to observe-port both
[huawei-GigabitEthernet0/0/7]dis th
[huawei-GigabitEthernet0/0/7]qu
[huawei]interface GigabitEthernet0/0/8
[huawei-GigabitEthernet0/0/8]description Up_Tel-itv
[huawei-GigabitEthernet0/0/8]port link-type access
[huawei-GigabitEthernet0/0/8]port default vlan 43
[huawei-GigabitEthernet0/0/8]dis th
[huawei-GigabitEthernet0/0/7]qu
[huawei]interface GigabitEthernet0/0/6
[huawei-GigabitEthernet0/0/6]description PC-Gck
[huawei-GigabitEthernet0/0/6]port link-type access
[huawei-GigabitEthernet0/0/6]port default vlan 43
[huawei-GigabitEthernet0/0/6]dis th
[huawei-GigabitEthernet0/0/6]qu
[huawei]interface GigabitEthernet0/0/10
[huawei-GigabitEthernet0/0/10]description To_MikroTik-PPPoE
[huawei-GigabitEthernet0/0/10]port link-type trunk
[huawei-GigabitEthernet0/0/10]port trunk pvid vlan 1119
[huawei-GigabitEthernet0/0/10]undo port trunk allow-pass vlan 1
[huawei-GigabitEthernet0/0/10]port trunk allow-pass vlan 43 45 100 1119
[huawei-GigabitEthernet0/0/10]dis th
[huawei-GigabitEthernet0/0/10]qu

2.抓直播源和iptv dhcp鉴权,教程点击

iptv dhcp鉴权教程点击

3.创建容器udpxy与msd_lite(支持IPv4/IPv6)

容器接口

/interface veth add name=udpxy_eth address=172.16.99.6/24 gateway=172.16.99.1

创建容器桥 网关

/interface bridge add name=docker_br igmp-snooping=yes
/ip address add interface=docker_br address=172.16.99.1/24

绑定接口

/interface bridge port add interface=udpxy_eth bridge=docker_br

创建容器

/container add file=amd_x86_64/udpxy_x86-64.tar interface=udpxy_eth root-dir=docker/images/udpxy start-on-boot=yes logging=no

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

web输入http://172.16.99.6:4022/status

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

4.创建itv vlan

/interface vlan add name=iTV vlan-id=43 interface=wan
/interface bridge add name=Up_iptv admin-mac=xx:xx:xx:xx:xx:xx        注:机顶盒mac
/interface bridge port add interface=udpxy_eth bridge=docker_br
/interface bridge port add interface=iTV bridge=Up_iptv

5.dhcp认证鉴权

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

填你机顶盒抓取的信息

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享! MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

获取ip说明成功

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

6.创建igmp-proxy

/routing igmp-proxy interface add interface=Up_iptv alternative-subnets=0.0.0.0/0 upstream=yes     注:上联口
/routing igmp-proxy interface add interface=Docker_eth upstream=no                                 注:下联口

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

7.电脑打开vlc测试下直播源

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik搭建IPTV组播转单播-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

8.映射端口

/ip firewall/nat add chain=dstnat protocol=tcp dst-port=2623 action=dst-nat to-addresses=172.16.99.6 to-ports=4022 content="udpxy_tcp"

9.源m3u制作格式
#EXTM3U\                                               注:文件格式
#EXTINF:-1 ,CCTV-1高清                                  注:频道名
http://abc.rb.cn:2623/udp/239.93.86.144:5140\           注:域名+端口号

 

HDP直播用的格式保存为txt或者tv

CCTV-1高清,http://域名+端口号/udp/组播源

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

2 评论

  1. 问一下楼主,如何DHCP认证上,有默认VLAN,然后还有个组拔VLAN这种情况怎么配置啊,我看你这个就是通过了一个VLAN43,我们本地还有一个组播VLAN99,\\这个该如何操作啊。

  2. 已经搞定了,感谢楼主。

发表评论

19
+1950天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图