MikroTik安装dnsplus服务器

作者 : 七界传说 发布时间: 2024-01-7 文章热度:813 共1240个字,阅读需4分钟。 本文内容有更新

目 录

dnsplus是缝合dnsmasq mosdns-v5 smartdns AdGuardHome做DNS Server解析服务

AdGuardHome做web界面管理

Windows 10下命令

docker pull --platform amd64 lkxlzx/dnsplus:x86

docker 转换成ros用的tra

docker save lkxlzx/dnsplus:x86 >dnsplus_x86-64.tar

安装包:dnsplus_x86-64.tar

快速通道:点击下载  密码:bgu5

MikroTik

容器虚拟接口创建命令:

/interface veth add name=Dnsplus_Eth address=192.168.8.5/24,2000:192:168:8::5/64 gateway=192.168.8.8 gateway6=2000:192:168:8::8

绑定内网桥接:

/interface bridge port add bridge=Bridge interface=Dnsplus_Eth

上传tar文件进file:

MikroTik安装dnsplus服务器-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建容器映射文件:

/container mounts add name=Dnsplus_dir src=/docker/dnsplus dst=/etc/dnsplus

配置映射端口与变量:

/container envs
add name=dnsplus_ev key=PORT value=3000
add name=dnsplus_ev key=START_DNSMASQ value=true
add name=dnsplus_ev key=START_MOSDNS value=true
add name=dnsplus_ev key=START_SMARTDNS value=true
/

说明:dnsplus2024.1.1更新
1.加入dnsmasq模块,配置文件名:dnsmasq.conf
2.添加系统变量:
START_DNSMASQ=true/false
START_MOSDNS=true/false
START_SMARTDNS=true/false
控制DNS模块的启用与禁用,可随意搭配DNS模块使用,AdGuardHome默认启动不可禁用
更新地址:

docker pull lkxlzx/dnsplus:arm64
docker pull lkxlzx/dnsplus:arm32v7
docker pull lkxlzx/dnsplus:x86

创建容器:

/container add file=amd_x86_64/dnsplus_x86-64.tar interface=Dnsplus_Eth envlist=dnsplus_ev hostname=dnsplus.lan root-dir=docker/images/dnsplus mounts=Dnsplus_dir dns=127.0.0.1 start-on-boot=yes

启动容器:手动点击Start
MikroTik安装dnsplus服务器-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

http://ip+3000访问

MikroTik安装dnsplus服务器-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

相关教程参考:设置ADGUARD点击

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

1 评论

  1. docker拉取了最新版2024.3.22更新的dnsplus:x86转成tar文件,在container中设置好后,启动不了。与dnsplus2024.1.1更新的dnsplus:x86的设置有区别吗?能否更新下操作步骤。用博主的dnsplus_x86-64.tar在container中是可以成功启动的。

发表评论

18
+1884天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图