MikroTik搭建mosdns服务器教程

作者 : 七界传说 发布时间: 2023-05-4 文章热度:4.62K 共1936个字,阅读需5分钟。

目 录

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

前言

routerOS支持docker,不过组件包是Container,路由版本是7.9(仅支持ARM、ARM64和x86平台)

在路由里直接拉取镜像不成功,Windows下搭建Docker环境,拉取镜像注意MikroTik路由平台,打包传进路由文件夹 ,我用amd_x86做的软路由

分享下大佬打包好的容器:下载  密码:bgu5

1.上传固件包Container

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

2.创建docker虚拟接口

/interface veth add name=Docker_Eth address=192.168.8.6/24 gateway=192.168.8.8

注:同网段做DNS服务器,IP为192.168.8.6 网关是路由网关

3.绑定内网桥接

/interface bridge port add interface=Docker_Eth bridge=Bridge

4.启用容器功能(默认是关闭)

/system/device-mode/update container=yes

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

5分钟内断电路由,注意不是重启

重启完成输入下面命令

/system/device-mode/pri

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

可以看到容器功能已经打开

5.配置config

/container/config set ram-high=0 registry-url="https://registry-1.docker.io" tmpdir=/docker/images username=root password=******

6.创建容器映射文件目录

/container/mounts/add name=mosdns_v5_dir src=/docker/mosdns_v5 dst=/etc/mosdns

注:dst=是容器里目录  src=是路由器file下文件名目录

7.创建容器

/container/add file=amd_x86_64/mosdns_x86-64_v5.1.3.tar interface=Docker_Eth hostname=mosdns.lan root-dir=/docker/images/mosdns_v5 mounts=mosdns_v5 dns=127.0.0.1 logging=yes
start-on-boot=yes

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

8.上传mosdns配置文件

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

正常状态是running     如何还是stopped状态 是没有mosdns配置文件

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

把mosdns配置文件传上路由目录文件夹/docker/mosdns_v5

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

 

MikroTik搭建mosdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

参考:不带国外分流配置

log:
  level: info
  production: false
  file: ./log.xml

plugins: 
  - tag: local_cache
    type: cache
    args:
      size: 10240
      lazy_cache_ttl: 86400
      dump_file: ./cache.dump
      dump_interval: 600

  - tag: ptr_forward
    type: forward
    args:
      concurrent: 3
      upstreams:
        - addr: https://223.5.5.5/dns-query
        - addr: https://120.53.53.53/dns-query
        - addr: tls://223.6.6.6
        - addr: tls://1.12.12.12
        - addr: 119.29.29.29
        - addr: 114.114.114.114
        - addr: 180.76.76.76

  - tag: foreign_doh
    type: forward
    args:
      concurrent: 3
      upstreams:
        - addr: https://1.1.1.1/dns-query
        - addr: https://8.8.4.4/dns-query
        - addr: tls://1.0.0.1
        - addr: tls://8.8.8.8

  - tag: ttl_sequence
    type: sequence
    args:
      - exec: ttl 30

  - tag: ptr_sequence
    type: sequence
    args:
      - exec: $ptr_forward

  - tag: dns_main
    type: sequence
    args:
      - exec: $local_cache
      - matches:
             - ptr_ip 192.168.0.0/16
        exec: goto ptr_sequence
      - exec: prefer_ipv4
      - exec: $foreign_doh
      - exec: $ttl_sequence


  - tag: udp
    type: udp_server
    args:
      entry: dns_main
      listen: "127.0.0.1:5757"

  - tag: tcp
    type: tcp_server
    args:
      entry: dns_main
      listen: "127.0.0.1:5757"

 

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

发表评论

19
+1975天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图