MikroTik搭建smartdns服务器教程

作者 : 七界传说 发布时间: 2023-05-18 文章热度:4.49K 共2697个字,阅读需7分钟。

目 录

MikroTik搭建smartdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

SmartDNS 是一个运行在本地的 DNS 服务器,SmartDNS 接受本地客户端的 DNS 查询请求,从多个上游 DNS 服务器获取 DNS 查询结果,并将访问速度最快的结果返回给客户端,提高网络访问速度。 同时支持指定特定域名IP地址,并高性匹配,达到过滤广告的效果

Doh mosdns   解析地址:192.168.8.7

Udp dnsmasq 解析地址:192.168.8.6

SmartDNS 解析地址:192.168.8.5    上游填 mosdns dnsmasq IP

Windows 11 安装Docker Desktop

教程地址:https://baijiahao.baidu.com/s?id=1750789202747593392&wfr=spider&for=pc

拉取容器

Windows下命令

docker pull --platform amd64 ghostry/smartdns:latest

docker 转换成ros用的tra

docker save ghostry/smartdns:latest >Smartdns_x86_64.tar

上传文件

MikroTik搭建smartdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建docker虚拟接口

/interface veth add name=Smartdns_Eth address=192.168.8.5/24 gateway=192.168.8.8

注:同网段做DNS服务器,IP为192.168.8.5 网关是路由网关

绑定内网桥接

/interface bridge port add interface=Smartdns_Eth bridge=Bridge

映射文件目录

/container/mounts/add name=smartdns_dir src=/docker/smartdns dst=/smartdns

MikroTik搭建smartdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

注:dst=容器目录  src=本地目录

创建容器

/container/add file=amd_x86_64/Startdns_x86_64.tar interface=Smartdns_Eth hostname=Startdns.lan root-dir=/docker/images/startdns mounts=smartdns_dir dns=127.0.0.1 logging=no start-on-boot=yes

MikroTik搭建smartdns服务器教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

注:logging=no 不输出日志

创建之后点Start启动,上传配置文件参考配置如下:

# Dns 服务器名称
server-name smartdns.lan

# 设置日志级别 off、fatal、error、warn、notice、info 或 debug
log-level error
# 日志文件路径
log-file /etc/smartdns/smartdns.log

# 本地监听端口
bind [::]:53 -no-dualstack-selectipn -no-speed-check
bind-tcp [::]:53 -no-dualstack-selectipn -no-speed-check
bind-tls [::]:853 -no-dualstack-selectipn -no-speed-check

# 上游服务器
server 192.168.8.6
server 192.168.8.7
# server 223.5.5.5
# server 119.6.6.6
# server 119.29.29.29
# server-https https://dns.alidns.com/dns-query
# server-https https://doh.pub/dns-query
# server-https https://dns.google/dns-query
# server-https https://cloudflare-dns.com/dns-query
# server-tls 1.12.12.12
# server-tls 120.53.53.53
# server-tls dns.alidns.com

# DDNS动态解析专用上游
server 223.5.5.5 -group ddns -exclude-default-group

# 备用
# server 8.8.8.8 -blacklist-ip -check-edns
# server-tcp 119.6.6.6
# server-tcp 223.5.5.5
# server-tcp 114.114.114.114
# server-tcp 223.5.5.5
# server-tls 1.12.12.12
# server-tls 120.53.53.53
# server-tls 119.29.29.29
# server-https https://cloudflare-dns.com/dns-query

# 域名结果 TTL
rr-ttl 600
# 允许的最小 TTL 值
rr-ttl-min 60
# 允许的最大 TTL 值
rr-ttl-max 600
# 允许返回给客户端的最大 TTL 值
rr-ttl-reply-max 60
# 缓存大小
cache-size 102400
# 缓存文件存放位置
cache-file /etc/smartdns/smartdns.cache
# 缓存获取
prefetch-domain yes
# 配置是否持久化缓存
cache-persist yes
# 过期缓存服务功能
serve-expired yes
# 配置过期缓存超时时间
serve-expired-ttl 259200
# 配置过期缓存响应TTL
serve-expired-reply-ttl 30
# 过期缓存预获取时间
serve-expired-prefetch-time 86400
# cache定时保存
# cache-checkpoint-time 86400
# 关闭TYPE65记录查询
force-qtype-SOA 65
# 双栈IP优选关闭[yes|no]
dualstack-ip-selection yes
# 双栈IP优选阈值 [0-1000]
dualstack-ip-selection-threshold 1000
# 允许纯IPV6地址
dualstack-ip-allow-force-AAAA no
# 禁止IPv6 AAAA记录解析 [yes|no]
force-AAAA-SOA no
# 允许返回给客户最大IP数量
max-reply-ip-num 8
# 最快响应DNS结果,DNS查询等待时间最短,返回IP地址可能不是最快
response-mode fastest-response
# 关闭特定域名缓存
domain-rules /.***.com/ -no-cache
# DDNS域名从阿里解析
nameserver /.***.com/ddns

注:***域名自己改      分享镜像包:下载  密码:bgu5

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

1 评论

  1. 可以介绍一下ros中openwrt安装吗?我安装成功后却无法使用,始终DNS解析有问题。用了两个版本都是如此?请大神研究一下呢?

发表评论

19
+1950天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图