HUAWEI防火墙配置IPv6无状态自动生成

作者 : 七界传说 发布时间: 2024-04-6 文章热度:150 共2620个字,阅读需7分钟。

HUAWEI防火墙配置IPv6无状态自动生成-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

<HUAWEI> system-view
[HUAWEI] dhcpv6 duid ll                     ll(MAC地址)方式生成DUID 
Warning: The DHCP unique identifier should be globally-unique and stable. Are you sure to change it? [Y/N]y
Info: The configuration has been written to hda1:/dhcp/dhcp-duid.txt.
[HUAWEI] disp ipv6 int br                   查看IPv6地址
[HUAWEI] disp arp | in 192.168.8.111        查看ARP

创建PPPoE接口

interface Dialer1                  进入PPPoE接口配置
link-protocol ppp
ppp chap user xxxxxx               拨号帐号
ppp chap password cipher xxxxxx    拨号密码
ppp pap local-user xxxxxx password cipher xxxxxx
ppp ipcp dns admit-any
description ChinaMobile
ip address ppp-negotiate
dialer user xxxxxx
dialer bundle 1
service-manage ping permit
ipv6 enable                        使能IPv6功能
ipv6 address auto link-local       自动生成链路本地地址
ipv6 address auto global default   使能无状态自动生成IPv6全局地址,学习RA报文中的源地址并将其作为IPv6缺省路由
dhcpv6 client pd cmcc_pd           使能DHCPv6 PD客户端功能,dhcpv6-prefixname自定义
ipv6 mtu 1420                      配置接口MTU

创建基于VLAN接口配置DHCP服务

interface Vlanif10                    进入VLAN接口配置
ipv6 enable                           使能IPv6功能
ipv6 address cmcc_pd ::192:168:8:8/64 绑定获取的地址前缀并分配接口地址和指定前缀长度
ipv6 address auto link-local          自动生成链路本地地址
undo ipv6 nd ra halt                  使能系统发布RA报文
ipv6 mtu 1420                         配置接口MTU
ip address 192.168.8.8 255.255.255.0
dhcp server mask 255.255.255.0
dhcp server ip-range 192.168.8.1 192.168.8.254
dhcp select interface
dhcp server gateway-list 192.168.8.8
dhcp server excluded-ip-address 192.168.8.1 192.168.8.7
dhcp server excluded-ip-address 192.168.8.201 192.168.8.254
dhcp server static-bind ip-address 192.168.8.2 mac-address 0000-e03f-0350
dhcp server dns-list 192.168.8.9
alias DHCP_Server
service-manage http permit
service-manage https permit
service-manage ping permit
service-manage ssh permit
service-manage telnet permit

上联光猫接口配置

interface GigabitEthernet 0/0/9        GE9是上联光猫接口
pppoe-client dial-bundle-number 1      关联拨号接口
ip address 192.168.86.11 255.255.255.0 光猫互访地址
alias Up_HN8145XR
description Up_GE:ETH1

创建IPv4与IPv6路由

ip route-static 0.0.0.0 0 Dialer 1  创建IPv4路由
ipv6 route-static :: 0  Dialer 1    创建IPv6路由
disp cur | inc route-st             查看路由

创建IPv4与IPv6 DNS

dns server 192.168.8.9              内网有DNS服务器,自行填写例:223.5.5.5
dns server ipv6 2000:192:168:8::999 内网有DNS服务器,自行填写例:2400:3200::1
disp cur | inc dns                  查看dns
disp dhcpv6 client                  查看ipv6接口地址
disp int xg0/0/1 | inc Last 300 seconds| Input | Output 查看接口流量
disp int Eth bri

创建IPv6 DHCP_Server

dhcpv6 pool Vlanif1000
address prefix 2000:192:168:8::/64 life-time 86400 86400
dns-server 2000:192:168:8::999

interface Vlanif 1000
ipv6 enable
dhcpv6 server Vlanif1000
ipv6 address 2000:192:168:8::8/64 
ipv6 address auto link-local    
undo ipv6 nd ra halt
alias dhcpv6_server

IPv4 中继

ip address 192.168.8.2 255.255.255.0
alias dhcpv4_relay
dhcp select relay
ip relay address 192.168.8.8

全局IPv4 中继

dhcp enable
dhcp server group dhcp-group
dhcp-server 192.168.8.8
int g 0/0/1
dhcp select relay
dhcp relay server-select dhcp-group

IPv6 中继

ipv6 enable
ipv6 address 2000:192:168:8::2/64 
ipv6 address auto link-local 
alias dhcpv6_relay
dhcpv6 relay destination 2000:192:168:8::8

加入安全区域

firewall zone trust
add interface GigabitEthernet 0/0/1
firewall zone untrust
add interface Dialer1

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

发表评论

19
+1923天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图