MikroTik配置Wireguard与PC,手机互联

作者 : 七界传说 发布时间: 2022-05-10 文章热度:7.12K 共1921个字,阅读需5分钟。

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

WireGuard有多个平台的应用程序,包括Windows版本,可以从官网下载:点击访问

假设MikroTik外网IP是220.166.123.184

ros版本是v7.8

防火墙有特殊规则要放行

创建两条:

ip firewall filter/add action=accept chain=input comment="allow WireGuard Port" dst-port=19527 protocol=udp place-before=1
ip firewall filter/add action=accept chain=input comment="allow WireGuard traffic" src-address=192.168.112.0/24 place-before=1

 

PC和手机作为请求发起端,ROS作为接收端,分配给隧道互联IP如下:

  • 路由端的wireguard接口IP是:192.168.112.1/24
  • 电脑端的wireguard接口IP是:192.168.112.123/32
  • 手机端的wireguard接口IP是:192.168.112.100/32

命令创建:

/interface wireguard add name=WireGuard listen-port=19527 mtu=1450 #名称PC 默认端口改为19527
/ip address add address=192.168.112.1/24 interface=WireGuard    #给wg接口创IP地址

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

Windows的WireGuard程序安装好,打开程序,并选择“新建空隧道”

然后在创建新隧道对话框中,写入以下配置

PC端IPv4模板:

[Interface]
PrivateKey = GJBqmDSpBvfN*******         #Windows端上Wg的key
ListenPort = 443                         #监听端口
Address = 192.168.112.123/32             #Windows上Wg接口IP地址
mtu = 1450                               #服务端和客户端填一样
dns = 177.157.6.4                        #内网DNS服务器

[Peer]
PublicKey = G12RByixSbe98K******         #MikroTik路由上Wg的public key
PresharedKey = 8GOEyAHj9Obau4******      #预共享密钥
AllowedIPs = 0.0.0.0/1,128.0.0.0/1       #允许通过的IP地址段
Endpoint = 220.166.123.184:19527         #MikroTik路由公网IP地址或者域名+端口  测试:IPv6+IPv4都正常能使用
PersistentKeepalive = 30                 #默认

说明:
[interface]:为Windows接口配置,这除了自动生成的私钥,需要添加WireGuard接口IP地址192.168.112.123/32
[peer]:添加对端的public key,并指定endpoint(RouterOS的外网IP地址)为220.166.123.184端口是19527,并添加允许通过的IP地址段,allowedIPs为0.0.0.0/1, 128.0.0.0/1 ,keepalive作用是每隔30秒发送一个询问数据请求,用于nat会话连接保持

创建完成后如下:

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik路由上WireGuard Peer中做相应的配置,需要指定public key(对端windows的公钥)和allowed address,无需指定endpoint参数

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

配置完成后,在windows电脑点击连接,如果连接成功后,状态会显示已连接

配置手机端:

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

添加路由端peers:

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
互相ping测试如下:

路由到PC-手机

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

PC到路由-手机

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
补充:手机到WireGuard与IPv4 IPv6互联

Server端:(最新版本支持Preshared Key 预共享密钥)

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享! 手机端:

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

PC端IPv6模板:

[Interface]
PrivateKey = GJBqmDSpBvfN*******
ListenPort = 443
Address = 172.16.66.3/32,2000:fd11:192:168::4568/128
DNS = 192.168.8.5,2000:fd11:192:168::555
MTU = 1450

[Peer]
PublicKey = G12RByixSbe98K******
PresharedKey = 8GOEyAHj9Obau4******
AllowedIPs = 0.0.0.0/1,128.0.0.0/1,::/1,128::/1
Endpoint = 220.166.123.184:19527
PersistentKeepalive = 10

互通测试:

MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
MikroTik配置Wireguard与PC,手机互联-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

1 评论

  1. 按帖子配置了。windows上wg显示连通,但是ping不同ros,不知什么原因。

发表评论

18
+1884天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图