MikroTik配置rip is-is ospf bgp bfd简单教程

作者 : 七界传说 发布时间: 2023-11-16 文章热度:1.19K 共3920个字,阅读需10分钟。

目 录

先创建异地互联桥梁Wireguard组网参考:点击

1.rip配置

B端:

/routing rip instance add vrf=main afi=ipv4 redistribute=connected,static disabled=no

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

/routing rip interface-template add instance=rip-instance-1 interfaces=wg-Client use-bfd=yes disabled=no

 

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

A端:

/routing rip instance add vrf=main afi=ipv4 redistribute=connected,static disabled=no
/routing rip interface-template add instance=rip-instance-1 interfaces=wg-GS use-bfd=yes disabled=no

2.bfd配置两边都一样命令

/routing bfd configuration add interfaces=all vrf=main min-tx=0.2 min-rx=0.2 multiplier=5 disabled=no

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

查看链接状态

/routing rip neighbor pri
0 D instance=rip-instance-1 address=172.16.2.1%wg-Client routes=0 packets-total=3
last-update=2s
/routing route pri where rip

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

/routing bfd session pri
Flags: U - up, I - inactive
0 U multihop=no vrf=main remote-address=172.16.2.2%wg-GS
local-address=172.16.2.1%wg-GS state=up state-changes=1 uptime=2m2s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s packets-rx=696
packets-tx=701

2.ospf参考教程:点击

3.ipv6-bgp配置

EBGP与IBGP下面以EBGP为例:创建A端ipv6互通内网地址:

/ipv6 address add interface=wg-GS address=2000:9999::1/64 from-pool="" advertise=no disabled=no

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

创建B端ipv6互通内网地址:

/ipv6 address add interface=wg-Client address=2000:9999::2/64 from-pool="" advertise=no disabled=no

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
A端创建bgp默认Templates:

/routing bgp template set numbers=0 disabled=yes
/routing bgp template add name="AS_GS" router-id=4.4.4.1 as=65501 use-bfd=yes multihop=yes address-families=ipv6 disabled=no output.redistribute=connected

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

/routing bgp connection add remote.address=2000:9999::2/128 remote.as=65502 local.address=2000:9999::1 local.role=ebgp name=bgp1 templates=AS_GS as=65501 address-families=ipv6 router-id=4.4.4.1

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

 

B端创建bgp默认Templates:

/routing bgp template set numbers=0 disabled=yes
/routing bgp template add name="AS_Server" router-id=4.4.4.2 as=65502 use-bfd=yes multihop=yes address-families=ipv6 disabled=no output.redistribute=connected

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

/routing bgp connection add remote.address=2000:9999::1/128 remote.as=65501 local.address=2000:9999::2 local.role=ebgp name=bgp1 templates=AS_Server as=65502 address-families=ipv6 router-id=4.4.4.2

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

查看连接状态

/routing bgp session pri

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

/routing route pri where bgp

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

检测下链接是否互通:

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

4.is-is配置简单4台异地环境测试下(版本RouterOS 7.13)

R1端创建EoIP

/interface eoip add name=isis-DAi-1 mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=1
/interface eoip add name=isis-DAi-2 mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=2
/interface eoip add name=isis-DAi-3 mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=3
/ip address add interface=isis-DAi-1 address=172.191.1.1/30
/ip address add interface=isis-DAi-2 address=172.191.2.1/30
/ip address add interface=isis-DAi-3 address=172.191.3.1/30
/routing isis instance add afi=ip system-id=9999.cdef.0001 areas=11.2222 
/routing isis interface-template add instance=isis-instance-1 interfaces=Bridge,isis-DAi-1,isis-DAi-2,isis-DAi-3 levels=l1,l2
/routing isis export show-sensitive

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

R2端创建EoIP

/interface eoip add name=isis-DAi mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=1
/ip address add interface=isis-DAi address=172.191.1.2/30
/routing isis instance add afi=ip system-id=1111.abab.0002 areas=11.2222 
/routing isis interface-template add instance=isis-instance-1 interfaces=Bridge,isis-DAi levels=l2
/routing isis export show-sensitive

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

R3端创建EoIP

/interface eoip add name=isis-DAi mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=2
/ip address add interface=isis-DAi address=172.191.2.2/30
/routing isis instance add afi=ip system-id=1111.acac.0003 areas=11.2222 
/routing isis interface-template add instance=isis-instance-1 interfaces=Bridge,isis-DAi levels=l2
/routing isis export show-sensitive

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

R4端创建EoIP

/interface eoip add name=isis-DAi mtu=1500 arp=reply-only remote-address=填对端域名 keepalive=3,3 tunnel-id=3
/ip address add interface=isis-DAi address=172.191.3.2/30
/routing isis instance add afi=ip system-id=1111.adad.0004 areas=11.2222 
/routing isis interface-template add instance=isis-instance-1 interfaces=Bridge,isis-DAi levels=l2
/routing isis export show-sensitive

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

查看连接状态UP表示连接成功

/routing isis neighbor pri

 

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!

查看路由Ai表示能互通

/routing route pri where is-is,ospf,bgp

MikroTik配置rip is-is ospf bgp bfd简单教程-七界传说丨关注分享网络、硬件、维护、游戏、主题、虚拟化、软件分享!
大佬们有更好的方式欢迎进群交流右下角Q群点击

 

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。

发表评论

19
+1975天安全运行
主题分享
0
+0篇本周更新
更新我快乐

VIP免费下载全站资源

立即了解

本站支持IPv6访问 本站支持SSL安全访问

站点地图